MAXEYE CMMB Signal Generation Toolkit Help

The MAXEYE CMMB Signal generation toolkit contains VIs that can be used for generating signals with National Instruments hardware or generate signals in simulation mode as per the CMMB Standard GY/T 220.1-2006. This document has information about the toolkit Labview API VIs to help engineers for programming.

____________________________________________________________________________________________________

For more information regarding this help please contact info@maxeyetech.com


MaxEye CMMB SG Initialize.vi

This VI creates MaxEye CMMB Generation Handle with the default values and passes the handle to the later VIs.

MaxEye CMMB SG Initialize.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - CMMB Signal Generation

For more details on this help, please write to us at
info@maxeyetech.com


MaxEye CMMB RFSG Create and Download Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the CMMB Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size, allocates on board memory space for writing waveform.
iii. Creates the CMMB waveform as per the configured parameters.
iv. Writes the created waveform in the RFSG on board memory.

MaxEye CMMB RFSG Create and Download Waveform.vi

MAXEYE TECHNOLOGIES Private Limited
Digital Video Toolkits - CMMB Signal Generation


MaxEye CMMB SG Create and Save Waveform.vi

This VI perfoms the following.

i. Checks the configuration parameters in the CMMB Signal Generation handle and returns an error if the configuration is not valid.
ii. Computes the waveform size and returns it to the user
iii. Creates the CMMB waveform as per the configured parameters.
iv. Writes the created waveform in the file as per the waveform file path location configured by the user

MaxEye CMMB SG Create and Save Waveform.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Read Waveform From File I8.vi

This VI reads the CMMB waveform from the given file location based on the value configured in the count input parameter. The number of bytes read from the file is equal to the value of the count. The data is read continuously from the file.

The default value of the count is 1.

MaxEye CMMB SG Read Waveform From File I8.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Number of Frames.vi

This VI configures the total number of frames property in the CMMB signal generation toolkit. The toolkit uses the same frame configuration for all the frames and the payload is continuous across frames.

The default value is 1.

MaxEye CMMB SG Set Number of Frames.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Signal Bandwidth.vi

This VI configures the value for signal bandwidth property, in Hz in the CMMB Signal Generation handle. The signal bandwidth determines the IFFT sampling frequency and IQ rate of the generated complex waveform. The valid enum values for the signal bandwidth are 0 (2 MHz) and 1 (8 MHz).

The default value is 1 (8 MHz).

MaxEye CMMB SG Set Signal Bandwidth.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Center Frequency.vi

This VI configures the value for Center Frequency Property, in Hz in the CMMB Signal Generation handle. The toolkit uses this property to create Network Information Table (NIT) as per the CMMB standard requirement. For more details refer Table 3, section 6.2 in the standard GY/T 220.2-2006.

The default value is 466 MHz.

MaxEye CMMB SG Set Center Frequency.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Region Index.vi

This VI configures the Regional Index property in the CMMB signal generation handle. Regional Index forms first half of the Transmitter ID sequences, which are used to identify the area where a transmitter is located. The range of values that can be given as input to this is 0 to 127.

Default value for this is 0.

MaxEye CMMB SG Set Region Index.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Transmission Identifier.vi

This VI configures the Transmitter Index property in the CMMB signal generation handle. This parameter is used to identify different transmitters located in a same area ( Selected basrd on Region Indentifier). The valid values for Transmitter Index property is from 128 to 255.

The default value is 128.

MaxEye CMMB SG Set Transmission Identifier.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Number of SLCH's.vi

This VI configures the Number of SLCH's property in the CMMB signal generation toolkit. The valid values are from 1 to 39. If the Payload Mode property is set to Multiplexed File Mode the Number of SLCH's property and other SLCH related configurations are read from the Multiplexed File Mode and the user configured value is ignored.

The default value is 1.

MaxEye CMMB SG Set Number of SLCH's.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Payload Mode.vi

This VI configures the Payload Mode property in the CMMB Signal Generation handle. The valid values for the Payload Mode property are

0 (PN Sequence) - Specifies that the toolkit uses a Galois pseudonoise (PN) bit sequence with configurable order and seed. The seed is the initial state of the PN generator shift register.

1 (User Defined Bits) - Specifies that the toolkit repeats the user-supplied bit pattern to achieve the necessary payload length.

2 (Test Pattern) - Specifies that toolkit uses the value set in the Payload Test Pattern property as a payload for creating the waveform. The length of the Test Pattern is 8 bits. This value is the default.

3 (Multiplex File) - Specifies that the toolkit uses the Multiplex Frame Structure (MFS) as a payload for creating the waveform. Use this payload mode for creating the signals as per the CMMB standard requirements. All SLCH configuration parameters are read from the MFS file in this payload and user defined configuration is ignored.

4 (MFS File by SLCH) - Specifies that toolkit uses separate MFS files as a payload per each SLCH. In this payload mode user need to configure each SLCH configuration parameters.

MaxEye CMMB SG Set Payload Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Multiplexed File Path.vi

This VI configures the Multiplexed File Path property in the DTMB Signal Generation handle. The toolkit reads the Multiplexed File Stream (MFS) data from the binary file for generating the signal when the Payload Mode property is set to Multiplexed File Mode. The Video, Audio and Data streams are multiplexed using Multiplexed File Format as per the CMMB standard GY/T 220.2. For more details refer to the standard.

MaxEye CMMB SG Set Multiplexed File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Headroom.vi

This VI configures the Head room property in the CMMB Signal Generation handle. The toolkit uses this value for scaling the waveform. If the PAPR of the signal is higher than the Head room value then the toolkit clips the signal. To avoid clipping Head room value should be higher than PAPR of the signal.

The default value is 12 dB.

MaxEye CMMB SG Set Headroom.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Waveform File Path.vi

The VI configures the file location for the Waveform File Path property in CMMB Signal Generation handle. The toolkit saves the generated waveform in the file when MaxEye CMMB RFSG Create and Save Waveform API VI is used for the wavefrom creation.

MaxEye CMMB SG Set Waveform File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Oversampling Enabled.vi

This VI configures the Oversampling Enabled property in the CMMB Signal Generation handle. If this property is set to True then the toolkit resamples the generated signal based on the value configured by the user for the Output Sampling Rate property.

The valid values are True and False. The default value is False.

MaxEye CMMB SG Set Oversampling Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Output Sampling Rate.vi

This VI configures the Output Sampling Rate (Hz) property of the CMMB Signal Generation handle.
The toolkit resamples the generated signal to a sampling rate equal to the Output Sampling Rate only if the Over Sampling Enabled property is set to 1(True). If this value is zero then toolkit generates the signal at a default sampling rate which is in turn dependent on the Bandwidth.

MaxEye CMMB SG Set Output Sampling Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Output Waveform Sample Width.vi

This VI configures the Sample Width property in the CMMB Signal Generation handle. The toolkit uses this value only when MaxEye CMMB SG Create and Save Waveform API VI is used for storing the generated waveform in the file.

If the Sample Width property is set to 0(8-bit) the toolkit uses 8 bits for quantizing I and Q sample and if it is set to 1(16-bit) the toolkit uses 16 bits for quantizing the I and Q samples.

MaxEye CMMB SG Set Output Waveform Sample Width.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Close Handle.vi

This VI closes the CMMB Signal Generation handle and resources associated with it.

MaxEye CMMB SG Close Handle.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH Configuration.vi

This VI configures the Control Logical Channel (CLCH) properties in the CMMB Signal generation handle. The help for the each of the CLCH properties can be found in the proeprty specific API VIs. This API is used for configuring the multiple properties using the CLCG Configuration cluster for ease of use.

MaxEye Technologies Recommends to use property specific API VIs to avoid compatibility issues with the Future release of this software.

MaxEye CMMB SG Set CLCH Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH Modulation Scheme.vi

This VI configures Modulation Scheme in the CMMB signal generation handle. The valid ring values are 0 (BPSK), 1 (QPSK) and 2 (16 QAM). For the constellation mapping details, refer to Figure 11, Figure 12 and Figure 13 of GYT220.1 [Framing Structure] of CMMB Standard.

The default value is 1 (QPSK).

MaxEye CMMB SG Set CLCH Modulation Scheme.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH LDPC Coding Rate.vi

This VI configures CLCH LDPC Coding Rate property in the CMMB Signal Generation handle. The valid values for the Code Rate property is 0 (1/2) and 1 (3/4).

The default value for the Code Rate is 0 (1/2).

MaxEye CMMB SG Set CLCH LDPC Coding Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH RS Encoding Rate.vi

This VI configures the RS Code Rate property in the CMMB signal generation handle. The valid values are 0 (RS(240,240)), 1 (RS(240,224)), 2 (RS(240,192)), 3 (RS(240,176)).

For CLCH, RS Code Rate is fixed at RS(240,240). The RS Code Rate selection determines the input to the RS encoder and the number of parity bytes to be generated to get a total output of 240 bytes.

The Default value is RS(240,240).

MaxEye CMMB SG Set CLCH RS Encoding Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH Interleaving Mode.vi

This VI configures the Interleaver Mode property in the CMMB signal generation handle. The valid ring values are 0 (Interleaver Mode 1), 1 (Interleaver Mode 2) and 2 (Interleaving Mode 3). For Signal Bandwidth of 2MHz, Bf - 2MHz, Mode 1 is used only in case of BPSK constellation; Mode 2 is used only in case of QPSK constellation; Mode 2 is used only in case of 16QAM constellation.

The Interleaver parameters vary depending upon the LDPC coding rate. For more details refer to Table 2 (MI parameters of bit interleaver) of GYT220.1 [Framing Structure] of CMMB Standard. The default value is Mode 0.

MaxEye CMMB SG Set CLCH Interleaving Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set CLCH Scrambler Initial Value.vi

This VI configures the Scrambler Initial Value for the CLCH channel in the CMMB signal generation handle. The valid values are 0 (0000 0000 0001), 1 (0000 1001 0011), 2 (0000 0100 1100), 3 (0010 1011 0011), 4 (0111 0100 0100), 5 (0000 0100 1100), 6 (0001 0110 1101) and 7 (1010 1001 0011)

The default initial value is 0 (0000 0000 0001).

MaxEye CMMB SG Set CLCH Scrambler Initial Value.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Configuration.vi

This VI configures the Service Logical Channels (SLCH) properties in the CMMB Signal generation handle. The help for the each of the SLCH properties can be found in the proeprty specific API VIs. This API is used for configuring the multiple properties using the SLCH Configuration cluster for ease of use.

MaxEye Technologies Recommends to use property specific API VIs to avoid compatibility issues with the Future release of this software.

MaxEye CMMB SG Set SLCH Configuration.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Number of Time Slots.vi

This VI configures the Number of Slots property in the CMMB signal generation toolkit for the user configured SLCH index. The valid values for the SLCH index is from 0 to 39 and the valid value for the Number of Slots property is 1 to 39. The toolkit returns an error if the sum of the Number of Slots value for all the SLCHs exceed the maximum allowed value of 39.

The default value for SLCH index is 0 and for the Number of Slots is 1.

MaxEye CMMB SG Set SLCH Number of Time Slots.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH LDPC Coding Rate.vi

This VI configures Coding Rate property in the CMMB Signal Generation handle for the selected SLCH Index. The valid values for the SLCH Index is from 0 to 39 and the valid values for the Code Rate property is 0 (1/2) and 1 (3/4).

The default value for SLCH Index is 0 and the Code Rate is 0 (1/2).

MaxEye CMMB SG Set SLCH LDPC Coding Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH RS Encoding Rate.vi

This VI configures the RS Code Rate property in the CMMB signal generation handle for the configured SLCH index. The valid values for the RS Encoding Rate is 0 (RS(240,240)), 1 (RS(240,224)), 2 (RS(240,192)), 3 (RS(240,176)). The valid values for the SLCH index is form 1 to 39.

The RS Code Rate selection determines the input to the RS encoder and the number of parity bytes to be generated to get a total output of 240 bytes.

The Default value for RS Encoding Rate property is 0 (RS(240,240)) and for the SLCH index is 0.

MaxEye CMMB SG Set SLCH RS Encoding Rate.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Modulation Scheme.vi

This VI configures Modulation Scheme property in the CMMB signal generation handle for the configured SLCH index. The valid values are 0 (BPSK), 1 (QPSK) and 2 (16 QAM). For the constellation mapping details, refer to Fig 11, Fig 12 and Fig 13 of GYT220.1 [Framing Structure] of CMMB Standard. The valide values for the SLCH index are from 0 to 39.

The default value for the SLCH index is 0 and for the modulation scheme is 1 (QPSK).

MaxEye CMMB SG Set SLCH Modulation Scheme.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Interleaving Mode.vi

This VI configures the Interleaver Mode property in the CMMB signal generation handle for the given SLCH index. The valid values are 0 (Interleaver Mode 1), 1 (Interleaver Mode 2) and 3 (Interleaving Mode 3). For Signal Bandwidth of 2Mhz, Mode 1 is used only in case of BPSK constellation; Mode 2 is used only in case of QPSK constellation; Mode 3 is used only in case of 16QAM constellation.

The Mode values vary depending upon the LDPC coding rate. For more details refer to Table 2 (MI parameters of bit interleaver) of GYT220.1 [Framing Structure] of CMMB Standard. The default value is 0 (Interleaver Mode 1) and the default SLCH index value is 0. The valid SLCH index value is from 0 to 39.

MaxEye CMMB SG Set SLCH Interleaving Mode.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Scrambler Initial Value.vi

This VI configures the Scrambler Initial Value for the given SLCH channel in the CMMB signal generation handle based on the SLCH index value. The valid values for Scramble value is 0 (0000 0000 0001), 1 (0000 1001 0011), 2 (0000 0100 1100), 3 (0010 1011 0011), 4 (0111 0100 0100), 5 (0000 0100 1100), 6 (0001 0110 1101) and 7 (1010 1001 0011). The valid values for SLCH index is from 1 to 39.

The default initial value is 0 (0000 0000 0001) for the Scramble Initial Value and 0 for the SLCH index.

MaxEye CMMB SG Set SLCH Scrambler Initial Value.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Payload PN Order.vi

This VI configures the Payload PN Order property in the CMMB Signal Generation handle for the configured SLCH index. The PN order specifies the order (length of memory) of the pseudorandom bit sequence (PRBS) generator. This property is applicable only when the Payload property is set to PN Sequence.

The default value for the PN Order property is 9 and for the SLCH index is 0.

MaxEye CMMB SG Set SLCH Payload PN Order.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Payload PN Seed.vi

This VI configures the Payload PN seed in the CMMB Signal Generation handle for the given SLCH index. This property is applicable only when the Payload property is set to PN Sequence. The valide values for the SLCH index is from 1 to 39.

The default value for the PN seed is BEEFBEEF for the SLCH index is 0.

MaxEye CMMB SG Set SLCH Payload PN Seed.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Payload File Path.vi

This VI configures the Payload File Path property in the CMMB Signal Generation handle for the given SLCH index. The toolkit reads the payload data from the binary file for generating the signal when the Payload Mode property is set to MFS file by SLCH mode. In this payload mode user needs to configure all the SLCH related properties.

The Valid values for SLCH index is from 1 to 39.

MaxEye CMMB SG Set SLCH Payload File Path.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Payload Test Pattern.vi

This VI configures the Payload test pattern in the CMMB Signal Generation handle for the configured SLCH index.This property is applicable only when the payload property is set to test pattern.The valid Test Patterns are All 1s,All 0 s,10101010,11110000. The valid values for SLCH index is 1 to 39.

The default value for the Test Pattern is All 1s and default for the SLCH index is 1.

MaxEye CMMB SG Set SLCH Payload Test Pattern.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set SLCH Payload User Defined Bits.vi

This VI configures the Payload User Defined Bits property in the CMMB Signal Generation handle for the configured SLCH index. This property is applicable only when the Payload Mode property is set to User Defined Bits. The user defined bits should be array of 1s and 0s. The valid values for SLCH index is from 1 to 39.

MaxEye CMMB SG Set SLCH Payload User Defined Bits.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Impairments Enabled.vi

This VI configures the Impairments Enabled property in the CMMB Signal Generation handle. If this property is set to True then the toolkit adds the impairments to the generated signal as per the user configuration for the supported impairments.

The valid values are True and False. The default value is False.

MaxEye CMMB SG Set Impairments Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set AWGN Enabled.vi

This VI configures the AWGN Enabled property in the CMMB Signal Generation handle. If this property is set to True then the toolkit adds Additive White Gaussian Noise (AWGN) to the created waveform based on the value configured in the Carrier to Noise Ratio property.

The valid values are True and False. The default value is False.

MaxEye CMMB SG Set AWGN Enabled.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Carrier to Noise Ratio.vi

This VI configures the value for the Carrier to Noise ratio property, in dB in the CMMB Signal Generation handle. This value specifies the Carrier to Noise ratio of the generated signal.

The default value is 50dB.

MaxEye CMMB SG Set Carrier to Noise Ratio.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Frequency Offset.vi

This VI configures the value for the Frequency Offset property, in Hz in the CMMB Signal Generation Handle. The toolkit applies frequency offset to the created waveform based on the value configured in this property. The applied frequency offset is relative to the signal generator's carrier frequency.

The default value is 0.

MaxEye CMMB SG Set Frequency Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Clock Offset.vi

This VI configures the value for the Clock Offset property, in PPM in the CMMB Signal Generation handle. The toolkit applies the clock offset to the generated waveform based on this value. The applied clock offset is relative to the the clock frequency of the signal generator.

The default value is 0.

MaxEye CMMB SG Set Clock Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set I DC Offset.vi

This VI configures the I DC Offset, in % in the CMMB Signal Generation Handle. The toolkit adds the DC offset to the in-phase signal component (I) of the complex waveform as a percentage of the root mean square magnitude of the unaltered I signal.

The default value is 0.

MaxEye CMMB SG Set I DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Q DC Offset.vi

This VI configures the value for Q DC Offset property, in % in the CMMB Signal Generation Handle. The toolkit adds the DC offset to the quadrature-phase signal component (Q) of the complex waveform as a percentage of the root mean square magnitude of the unaltered Q signal.

The default value is 0.

MaxEye CMMB SG Set Q DC Offset.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set IQ Gain Imbalance.vi

The VI configures the value for the IQ Gain Imbalance property, in dB in the CMMB Signal Generation handle. This value specifies the ratio, in dB, of the mean amplitude of the in-phase (I) signal to the mean amplitude of the quadrature-phase (Q) signal.

The default value is 0.

MaxEye CMMB SG Set IQ Gain Imbalance.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Quadrature Skew.vi

This VI configures the value for Quadrature skew Property in degrees in the CMMB Signal Generation handle. Quadrature Skew specifies the deviation in angle from 90 degrees between the in-phase (I) and quadrature-phase (Q) signals.

The default value for the Quadrature Skew is 0.

MaxEye CMMB SG Set Quadrature Skew.vi

MAXEYE TECHNOLOGIES Private Limited


MaxEye CMMB SG Set Impairment Configuration.vi

This VI configures the Impairment properties in the CMMB Signal generation handle. The help for the each of the impairment properties can be found in the proeprty specific API VIs. This API is used for configuring the multiple properties using the Impairment Configuration cluster for ease of use.

MaxEye Technologies Recommends to use property specific API VIs to avoid compatibility issues with the Future release of this software.

MaxEye CMMB SG Set Impairment Configuration.vi

MAXEYE TECHNOLOGIES Private Limited